全自动画线源码副图指标公式-通达信公式 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

全自动画线源码副图指标公式[通达信公式]

相关标签:通达信四量图指标源码 、 通达信画线源码 、 通达信自动画线公式 、 通达信kdj副图源码 、 通达信鱼身副图源码 、 通达信主升源码副图 、 通达信高低点源码副图 、 通达信ox主图公式源码 、 通达信精绝花副图源码 、 通达信2560主副图源码 、 通达信版aaa副图源码 、 通达信kd指标公式源码 、 通达信顶底画线源码 、

 

下降压力线:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORWHITE,LINETHICK2;
HJ_1:=20;
HJ_2:=10;
HJ_3:=5;
HJ_4:=(CLOSE+HIGH+LOW+OPEN)/4;
HJ_5:=LOW+(HJ_4-LOW)+(CLOSE-LOW);
HJ_6:=LOW+(CLOSE-HJ_4);
HJ_7:=REF(HJ_5,1);
HJ_8:=REF(HJ_6,1);

支:STICKLINE(ISLASTBAR AND CLOSE>=HJ_7,HJ_7,HJ_7,30,1),COLORRED;
压:STICKLINE(ISLASTBAR AND CLOSE<HJ_7,HJ_7,HJ_7,30,1),COLORGREEN;
支1:STICKLINE(ISLASTBAR AND CLOSE>=HJ_8,HJ_8,HJ_8,30,1),COLORMAGENTA;
压1:STICKLINE(ISLASTBAR AND CLOSE<HJ_8,HJ_8,HJ_8,30,1),COLORFF8800;
HJ_9:=REF(HIGH,HJ_1)=HHV(HIGH,2*HJ_1+1);
HJ_10:=BACKSET(HJ_9,HJ_1+1);
HJ_11:=FILTER(HJ_10,HJ_1) AND HIGH=HHV(HIGH,HJ_1+1);
HJ_12:=BARSLAST(HJ_11);
HJ_13:=IF(HJ_11,CURRBARSCOUNT,0);
HJ_14:=IF(HJ_12,REF(HIGH,HJ_12),HIGH);
HJ_15:=IF(HJ_12,REF(HJ_13,HJ_12),HJ_13);
HJ_16:=REF(HJ_14,HJ_12+1);
HJ_17:=CONST(HJ_15);
HJ_18:=REF(HJ_15,HJ_12+1);
HJ_19:=CONST(HJ_18);
HJ_20:=REF(HJ_16,HJ_12+1);
HJ_21:=IF(CURRBARSCOUNT>HJ_19,0,1);
HJ_22:=DRAWLINE(CURRBARSCOUNT=HJ_19,HIGH,CURRBARSCOUNT=HJ_17,HIGH,1);
HJ_23:=REF(LOW,HJ_1)=LLV(LOW,2*HJ_1+1);
HJ_24:=BACKSET(HJ_23,HJ_1+1);
HJ_25:=FILTER(HJ_24,HJ_1) AND LOW=LLV(LOW,HJ_1+1);
HJ_26:=BARSLAST(HJ_25);
HJ_27:=IF(HJ_25,CURRBARSCOUNT,0);
HJ_28:=IF(HJ_26,REF(LOW,HJ_26),LOW);
HJ_29:=IF(HJ_26,REF(HJ_27,HJ_26),HJ_27);
HJ_30:=CONST(HJ_29);
HJ_31:=REF(HJ_28,HJ_26+1);
HJ_32:=REF(HJ_29,HJ_26+1);
HJ_33:=CONST(HJ_32);
低点支撑:DRAWLINE(CURRBARSCOUNT=HJ_33,LOW,CURRBARSCOUNT=HJ_30,LOW,1),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=HJ_33,LOW,ISLASTBAR,REF(LOW,HJ_33-1),1),POINTDOT,COLORYELLOW,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=HJ_30,LOW,ISLASTBAR,REF(LOW,HJ_30-1),1),POINTDOT,COLORYELLOW,LINETHICK2;
HJ_34:=REF(HIGH,HJ_2)=HHV(HIGH,2*HJ_2+1);
HJ_35:=BACKSET(HJ_34,HJ_2+1);
HJ_36:=FILTER(HJ_35,HJ_2) AND HIGH=HHV(HIGH,HJ_2+1);
HJ_37:=BARSLAST(HJ_36);
HJ_38:=IF(HJ_36,CURRBARSCOUNT,0);
HJ_39:=IF(HJ_37,REF(HIGH,HJ_37),HIGH);
HJ_40:=IF(HJ_37,REF(HJ_38,HJ_37),HJ_38);
HJ_41:=REF(HJ_39,HJ_37+1);
HJ_42:=CONST(HJ_40);
HJ_43:=REF(HJ_40,HJ_37+1);
HJ_44:=CONST(HJ_43);
HJ_45:=REF(HJ_41,HJ_37+1);
HJ_46:=IF(CURRBARSCOUNT>HJ_44,0,1);
压力:DRAWLINE(CURRBARSCOUNT=HJ_44,HIGH,CURRBARSCOUNT=HJ_42,HIGH,1),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=HJ_44,HIGH,ISLASTBAR,REF(HIGH,HJ_44-1),1),POINTDOT,COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=HJ_42,HIGH,ISLASTBAR,REF(HIGH,HJ_42-1),1),POINTDOT,COLORYELLOW;
HJ_47:=REF(LOW,HJ_2)=LLV(LOW,2*HJ_2+1);
HJ_48:=BACKSET(HJ_47,HJ_2+1);
HJ_49:=FILTER(HJ_48,HJ_2) AND LOW=LLV(LOW,HJ_2+1);
HJ_50:=BARSLAST(HJ_49);
HJ_51:=IF(HJ_49,CURRBARSCOUNT,0);
HJ_52:=IF(HJ_50,REF(LOW,HJ_50),LOW);
HJ_53:=IF(HJ_50,REF(HJ_51,HJ_50),HJ_51);
HJ_54:=CONST(HJ_53);
HJ_55:=REF(HJ_52,HJ_50+1);
HJ_56:=REF(HJ_53,HJ_26+1);
HJ_57:=CONST(HJ_56);
支撑:DRAWLINE(CURRBARSCOUNT=HJ_57,LOW,CURRBARSCOUNT=HJ_54,LOW,1);
HJ_58:=(压力+支撑)/2;
HJ_59:=CONST((压力+支撑)/2);
HJ_60:=IF(HJ_33<HJ_19,HJ_33,HJ_19);
中轨:DRAWLINE(CURRBARSCOUNT=HJ_60,HJ_58,ISLASTBAR,HJ_59,1),COLORYELLOW;
HJ_61:=REF(HIGH,HJ_3)=HHV(HIGH,2*HJ_3+1);
HJ_62:=BACKSET(HJ_61,HJ_3+1);
HJ_63:=FILTER(HJ_62,HJ_3) AND HIGH=HHV(HIGH,HJ_3+1);
HJ_64:=BARSLAST(HJ_63);
HJ_65:=IF(HJ_63,CURRBARSCOUNT,0);
HJ_66:=IF(HJ_64,REF(HIGH,HJ_64),HIGH);
HJ_67:=IF(HJ_64,REF(HJ_65,HJ_64),HJ_65);
HJ_68:=REF(HJ_66,HJ_64+1);
HJ_69:=CONST(HJ_67);
HJ_70:=REF(HJ_67,HJ_64+1);
HJ_71:=CONST(HJ_70);
HJ_72:=REF(HJ_68,HJ_64+1);
HJ_73:=IF(CURRBARSCOUNT>HJ_44,0,1);
L压力:DRAWLINE(CURRBARSCOUNT=HJ_71,HIGH,CURRBARSCOUNT=HJ_69,HIGH,1),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=HJ_71,HIGH,ISLASTBAR,REF(HIGH,HJ_71-1),1),POINTDOT,COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=HJ_69,HIGH,ISLASTBAR,REF(HIGH,HJ_69-1),1),POINTDOT,COLORYELLOW;
HJ_74:=REF(LOW,HJ_3)=LLV(LOW,2*HJ_3+1);
HJ_75:=BACKSET(HJ_74,HJ_3+1);
HJ_76:=FILTER(HJ_75,HJ_3) AND LOW=LLV(LOW,HJ_3+1);
HJ_77:=BARSLAST(HJ_49);
HJ_78:=IF(HJ_76,CURRBARSCOUNT,0);
HJ_79:=IF(HJ_77,REF(LOW,HJ_77),LOW);
HJ_80:=IF(HJ_77,REF(HJ_78,HJ_77),HJ_51);
HJ_81:=CONST(HJ_80);
HJ_82:=REF(HJ_79,HJ_77+1);
HJ_83:=REF(HJ_80,HJ_26+1);
HJ_84:=CONST(HJ_83);
L支撑:DRAWLINE(CURRBARSCOUNT=HJ_84,LOW,CURRBARSCOUNT=HJ_81,LOW,1),COLORYELLOW;
HJ_85:=(L压力+L支撑)/2;
HJ_86:=CONST((L压力+L支撑)/2);
HJ_87:=IF(HJ_84<HJ_71,HJ_84,HJ_71);
HJ_88:=DRAWLINE(CURRBARSCOUNT=HJ_87,HJ_85,ISLASTBAR,HJ_86,1);
MA0:MA(CLOSE,0),COLORYELLOW;
HJ_89:=INTPART(3*8/5);
HJ_90:=REF(HIGH,HJ_89)=HHV(HIGH,2*HJ_89+1);
HJ_91:=FILTER(HJ_90,HJ_89);
HJ_92:=BACKSET(HJ_91,HJ_89+1);
HJ_93:=FILTER(HJ_92,HJ_89);
HJ_94:=BACKSET(ISLASTBAR,BARSLAST(HJ_93)+1);
HJ_95:=HJ_94>REF(HJ_94,1);
DRAWLINE(HJ_93,HIGH,HJ_95,HIGH,1),POINTDOT,COLORYELLOW;
HJ_96:=INTPART(3*5/5);
HJ_97:=REF(HIGH,HJ_96)=HHV(HIGH,2*HJ_96+1);
HJ_98:=BACKSET(HJ_97,HJ_96+1);
HJ_99:=FILTER(HJ_98,HJ_96) AND HIGH=HHV(HIGH,HJ_96+1);
HJ_100:=BARSLAST(HJ_99);
HJ_101:=IF(HJ_99,CURRBARSCOUNT,0);
HJ_102:=IF(HJ_100,REF(HJ_101,HJ_100),HJ_101);
HJ_103:=CONST(HJ_102);
DINGBUTS11:REF(HJ_102,HJ_100+1),NODRAW;
HJ_104:=CONST(DINGBUTS11);
高点压力M:DRAWLINE(CURRBARSCOUNT=HJ_104,HIGH,CURRBARSCOUNT=HJ_103,HIGH,1),COLORYELLOW;
HJ_105:=REF(LOW,HJ_96)=LLV(LOW,2*HJ_96+1);
HJ_106:=BACKSET(HJ_105,HJ_96+1);
HJ_107:=FILTER(HJ_106,HJ_96) AND LOW=LLV(LOW,HJ_96+1);
HJ_108:=BARSLAST(HJ_107);
HJ_109:=IF(HJ_107,CURRBARSCOUNT,0);
HJ_110:=IF(HJ_108,REF(HJ_109,HJ_108),HJ_109);
HJ_111:=CONST(HJ_110);
HJ_112:=REF(HJ_110,HJ_108+1);
HJ_113:=CONST(HJ_112);
低点支撑M:DRAWLINE(CURRBARSCOUNT=HJ_113,LOW,CURRBARSCOUNT=HJ_111,LOW,1),COLORYELLOW;
HJ_114:=10;
HJ_115:=10;
HJ_116:=0;
HJ_117:=0;
HJ_118:=0;
HJ_119:=0;
HJ_120:=REF(HIGH,HJ_114)=HHV(HIGH,2*HJ_114+1);
HJ_121:=BACKSET(HJ_120,HJ_114+1);
HJ_122:=FILTER(HJ_121,HJ_114) AND HIGH=HHV(HIGH,HJ_114+1);
HJ_123:=BARSLAST(HJ_122);
HJ_124:=IF(HJ_122,CURRBARSCOUNT,0);
HJ_125:=IF(HJ_123,REF(HIGH,HJ_123),HIGH);
HJ_126:=IF(HJ_123,REF(HJ_124,HJ_123),HJ_124);
HJ_127:=REF(HJ_125,HJ_123+1);
HJ_128:=CONST(HJ_126);
HJ_129:=REF(HJ_126,HJ_123+1);
HJ_130:=CONST(HJ_129);
HJ_131:=REF(HJ_127,HJ_123+1);
高点压力1:DRAWLINE(CURRBARSCOUNT=HJ_130,HIGH,CURRBARSCOUNT=HJ_128,HIGH,1),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=HJ_130,HIGH,ISLASTBAR,REF(HIGH,HJ_130-1),1),POINTDOT,COLORYELLOW;
HJ_132:=REF(LOW,HJ_115)=LLV(LOW,2*HJ_115+1);
HJ_133:=BACKSET(HJ_132,HJ_115+1);
HJ_134:=FILTER(HJ_133,HJ_115) AND LOW=LLV(LOW,HJ_115+1);
HJ_135:=BARSLAST(HJ_134);
HJ_136:=IF(HJ_134,CURRBARSCOUNT,0);
HJ_137:=IF(HJ_135,REF(LOW,HJ_135),LOW);
HJ_138:=IF(HJ_135,REF(HJ_136,HJ_135),HJ_136);
HJ_139:=CONST(HJ_138);
HJ_140:=REF(HJ_137,HJ_135+1);
HJ_141:=REF(HJ_138,HJ_135+1);
HJ_142:=CONST(HJ_141);
低点支撑1:DRAWLINE(CURRBARSCOUNT=HJ_142,LOW,CURRBARSCOUNT=HJ_139,LOW,1),COLORYELLOW;
HJ_143:=(高点压力1+低点支撑1)/2;
HJ_144:=CONST((高点压力1+低点支撑1)/2);
HJ_145:=IF(HJ_142<HJ_130,HJ_142,HJ_130);
DRAWLINE(CURRBARSCOUNT=HJ_142,LOW,ISLASTBAR,REF(LOW,HJ_142-1),1),POINTDOT,COLORYELLOW;
HJ_146:=STRCAT(HYBLOCK,1);
HJ_147:=STRCAT(HJ_146,FGBLOCK);
HJ_148:=STRCAT(HJ_147,DYBLOCK);
HJ_149:=STRCAT(HJ_148,1);
DRAWTEXT_FIX(ISLASTBAR,0.03,0.99,0,STRCAT(HJ_149,GNBLOCK)),COLORCYAN;{-----------------------------------}DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容