您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

买卖操盘线买卖点位指标公式源码[同花顺公式]

相关标签:

 

黄线持股,灰线持币;买、卖位置有提示标注;机构进场、大顶(底)有提示。特别提醒:含有未来函数,最近显示的一个买卖点仅为参考买卖点!使用时候要注意。(任何指标都不要迷信,不要以为未来函数就不可信,大V的分析难道不是未来函数么?收盘价难道不是未来函数嘛?仁者见仁!)此指标买卖点 是以收盘价格为准计算的!盘中提示,均为动态提示,可能变动。好比收盘价,收盘前谁都不晓得是多少。

 

 

原理解析:

VAR3赋值:240日内最高价的最低值
VAR4赋值:100*(收盘价-VAR3)/VAR3
VAR5赋值:(收盘价-528日内最低价的最低值)/(528日内最高价的最高值-528日内最低价的最低值)*100
VAR6赋值:(收盘价-530日内收盘价的最低值)/(530日内收盘价的最高值-530日内收盘价的最低值)*100
VAR7赋值:0
VAR8赋值:收盘价-1日前的收盘价和0的较大值的34日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的7日[1日权重]移动平均*100
VAR9赋值:收盘价-1日前的收盘价和0的较大值的13日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的13日[1日权重]移动平均*100
VAR10赋值:如果收盘价16%之字转向的前1个波谷位置=0ANDHIGH>最低价+0.04,返回4,否则返回0
VAR11赋值:收盘价6%的之字转向>1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向<=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向<=3日前的收盘价6%的之字转向
VAR12赋值:收盘价6%的之字转向<1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向>=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向>=3日前的收盘价6%的之字转向
VAR13赋值:收盘价22%的之字转向>1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向<=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向<=3日前的收盘价22%的之字转向
VAR14赋值:收盘价22%的之字转向<1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向>=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向>=3日前的收盘价22%的之字转向
VAR15赋值:收盘价51%的之字转向>1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向<=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向<=3日前的收盘价51%的之字转向
VAR16赋值:收盘价51%的之字转向<1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向>=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向>=3日前的收盘价51%的之字转向
VAR17赋值:收盘价72%的之字转向>1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向<=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向<=3日前的收盘价72%的之字转向
VAR18赋值:收盘价72%的之字转向<1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向>=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向>=3日前的收盘价72%的之字转向
VAR19赋值:收盘价的2日指数移动平均-收盘价的150日指数移动平均
买1赋值:VAR10
买2赋值:(VAR11+VAR13+VAR15+VAR17)
卖1赋值:(VAR12+VAR14+VAR16+VAR18)
输出买:如果买1>0OR买2>0,返回最低价*0.99,否则返回无效数,线宽为3,画黄色
当满足条件买1>0OR买2>0时,在最低价*0.99位置书写文字,画红色
输出卖:如果卖1>0,返回最高价*1.01,否则返回无效数,线宽为3,画绿色
当满足条件卖1>0时,在最高价*1.02位置书写文字,画绿色
/*当满足条件(收盘价5%的之字转向>1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向)时,在最低价*0.98位置画1号图标 
当满足条件(收盘价5%的之字转向<1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向>=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向>=3日前的收盘价5%的之字转向)时,在最高价*1.01位置画2号图标
ZB赋值:VAR3的5日指数移动平均的5日指数移动平均*3, COLORSTICK
VARA赋值:如果VAR9ANDCROSS(收盘价的3日简单移动平均,收盘价的5日简单移动平均),返回20,否则返回0
K赋值:VAR7的5日指数移动平均*2, , COLORFF00FF
D赋值:K的5日指数移动平均, , 画白色
J赋值:K*3-D*2, ,画黄色
VARB赋值:收盘价位于收盘价的3日简单移动平均和收盘价的5日简单移动平均之间 AND J>10
HS赋值:成交量(手)/当前流通股本(手)*100, , 画绿色
VARE赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
VARF赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
当满足条件VAR11ANDCOUNT(VAR11,30)=1时,在最低价*0.95位置书写文字,线宽为1,COLORFF00FF
VAR1A赋值:如果VARE>0,返回VARE,否则返回0
VAR1B赋值:如果VAR14>=200ANDVAR13>=150,返回15,否则返回如果VAR14<=-200ANDVAR13<=-150,返回-15,否则返回VAR16+60
VAR1C赋值:VAR1A>48 AND VAR1B>60 AND VAR19<100
当满足条件VAR1CANDCOUNT(VAR1C,30)=1时,在最低价*0.95位置书写文字 ,画白色
N赋值:如果收盘价的有效数据周期数>=8,返回8,否则返回收盘价的有效数据周期数
AMOV赋值:成交量(手)*(收盘价+最低价+最高价)/3
MN赋值:AMOV的N日累和/成交量(手)的N日累和
输出NOTEXT1:如果收盘价>=MN,返回MN,否则返回无效数,线宽为3,画黄色
输出NOTEXT2:如果收盘价<MN,返回MN,否则返回无效数,线宽为3,画深灰色
MA30赋值:收盘价的30日简单移动平均
输出分析家公式网HTTP://WWW.70822.COM整理:1日前的30日内收盘价的最高值的2日简单移动平均,COLOR9DFFFF
输出支撑:1日前的30日内收盘价的最低值的2日简单移动平均,COLORABFF46
 

源码:

 

 

VAR3:=LLV(HIGH,240);/*240天(年线、48周线)内,最低的当日最高价*/VAR4:=100*(CLOSE-VAR3)/VAR3;/*较240天内最低价的涨幅*/VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;/*528天内与最高价-最低价相比,所占的百分比*/VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;/*当日收盘价与最低收盘价的差与530天内收盘价的高低差相比,所占的百分比*/VAR7:=0;VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;/* */VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);买1:=VAR10;买2:=(VAR11+VAR13+VAR15+VAR17);卖1:=(VAR12+VAR14+VAR16+VAR18);买:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),LINETHICK3,coloryellow;DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买'),colorred;卖:IF(卖1>0,HIGH*1.01,DRAWNULL),LINETHICK3,colorgreen;DRAWTEXT(卖1>0,HIGH*1.02,'卖'),colorgreen;/*DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);*/ ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);K:=EMA(VAR7,5)*2, , COLORFF00FF;D:=EMA(K,5), , colorwhite;J:=K*3-D*2, ,coloryellow;VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;HS:=VOL/CAPITAL*100, , colorgreen;VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'机构进场'),LINETHICK1,COLORFF00FF;VAR1A:=IF(VARE>0,VARE,0);VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大顶(底)') ,colorwhite;N:=IF(BARSCOUNT(C)>=8,8,BARSCOUNT(C));AMOV:=VOL*(C+L+H)/3;MN:=SUM(AMOV,N)/SUM(VOL,N);NOTEXT1:IF(C>=MN,MN,DRAWNULL),LINETHICK3,coloryellow;NOTEXT2:IF(C<MN,MN,DRAWNULL),LINETHICK3,colorgray;MA30:=MA(C,30);压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容