凤凰线副图指标公式源码-同花顺公式 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

凤凰线副图指标公式源码[同花顺公式]

相关标签:

 

凤凰线:凤凰线由蓝、绿、黄、红四种颜色的线柱和凤线(黄色)、凰线(白色)共同组成。凤凰线是对K线形态的进一步变形,因为经过一系列数据模型的演变,因此形态更加流畅,上涨、下跌的形态也更加明显。处于凤线上方的红、黄两色线柱代表资金流入动作明显,当资金持续流入,该指标上会出现红色向上箭头提示投资者买进;反之,处于凰线下方蓝、绿两色表示资金正在流出,若资金持续流出,该指标会发出绿色向下箭头提示投资者卖出。
使用时请结合其他技术指标、成交量、大盘走势等多因素进行综合判断。


N:=1;
XOPEN:=(REF(O,N)+REF(C,N))/2;
XCLOSE:=CLOSE;
XHIGH:=MAX(HIGH,XOPEN);
XLOW:=MIN(LOW,XOPEN);
VOLALITY:=MA(XHIGH-XLOW,8);
凰线:MA(XCLOSE,5)+VOLALITY/2;
凤线:MA(XCLOSE,5)-VOLALITY/2;
BU:=CROSS(XCLOSE,凰线);
SEL:=CROSS(凤线,XCLOSE);
VAR1:=BARSLAST(BU);
VAR2:=BARSLAST(SEL);
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2,0 ),colorred;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XHIGH,XCLOSE ,0,0 ),colorred;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XOPEN,XLOW ,0,0 ),colorred;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2,0 ),coloryellow;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XHIGH,XOPEN ,0,0 ),coloryellow;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XLOW ,0,0 ),coloryellow;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XCLOSE ,XOPEN ,2,0 ),colorgreen;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XOPEN ,XHIGH ,0,0 ),colorgreen;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XCLOSE,XLOW ,0,0 ),colorgreen;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XCLOSE ,XOPEN ,2,0 ),colorblue;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XCLOSE,XHIGH ,0,0 ),colorblue;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XOPEN,XLOW ,0,0 ),colorblue;
DRAWICON(REF(VAR1,1)>VAR2 AND VAR1=0,XLOW,1);
DRAWICON(REF(VAR2,1)>VAR1 AND VAR2=0,XHIGH,2);
TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.CXH99.COM '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容