麻烦老师帮忙把通达信的指标改写成文华指标-文华财经知识 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 期货公式>> 文华财经>> 文华财经知识>>正文内容

麻烦老师帮忙把通达信的指标改写成文华指标 [文华财经]

  • 咨询内容:  
    EMA21:=EMA(C,21),COLORYELLOW; EMA34:=EMA(C,34),COLORFF00FF; EMA60:=MA(C,60),COLORFFCC66; VAR2:=(2*CLOSE+HIGH+LOW)/4; VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4); 散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3; 庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3; DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'低吸',COLORred; DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.15,'高抛',COLORred; DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,4); DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,5); VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20); 卖出1:=IF(VARA>0 AND CROSS(VARC,VARA),90,100); DRAWICON(卖出1=90,H+0.05,11);DRAWTEXT(卖出1=90,H+0.15,'线逃',COLORYELLOW;
     买线:=EMA(CLOSE,2); 卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42); drawicon(CROSS(买线,卖线),l-0.06,10);drawicon(CROSS(80,"rsi.rsi1"),H+0.06,11);DRAWTEXT(CROSS(80,"rsi.rsi1"),H+0.06,'si80',COLORYELLOW;
    VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;A0:=(L+H+C*2)/4;A1:EMA(A0,m),COLORBLUE,LINETHICK2;A2:=EMA(A0,25),LINETHICK2;A1X:=(A1-REF(A1,1))/REF(A1,1)*100;A2X:=(A2-REF(A2,1))/REF(A2,1)*100;看多:PARTLINE(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))),,COLORMAGENTA;逃顶:PARTLINE(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X)))),COLORCYAN;买入持股:PARTLINE(A1X>=0,A1),COLORRED,LINETHICK3;卖出空仓:PARTLINE(A1X<0 AND A2X<0,A1),COLORGREEN,LINETHICK3;STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC; STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;UPQK:=LOW-REF(HIGH,1);STICKLINE(CLOSE>REF(CLOSE,1) AND UPQK>0,REF(HIGH,1),LOW,20,1),COLORFF00FF;DRAWTEXT(CLOSE>REF(CLOSE,1) AND UPQK>0,UPQK/2+REF(HIGH,1),'向上跳空',COLORFF00FF;DOWNQK:=REF(LOW,1)-HIGH;STICKLINE(CLOSE<REF(CLOSE,1) AND DOWNQK>0,REF(LOW,1),HIGH,20,1),COLORFFFF00;DRAWTEXT(CLOSE<REF(CLOSE,1) AND DOWNQK>0,DOWNQK/2+HIGH,'向下跳空',COLORFFFF00;MID :  MA(CLOSE,26);UPPER: MID + 2*STD(CLOSE,26),COLORYELLOW;LOWER: MID - 2*STD(CLOSE,26),COLORYELLOW;

     

     来源:程序化99

  • 文华技术人员:  参考:
     EMA21:=EMA(C,21),COLORYELLOW;  EMA34:=EMA(C,34),COLORFF00FF;  EMA60:=MA(C,60),COLORFFCC66;  VAR2:=(2*CLOSE+HIGH+LOW)/4;  VAR3:=IF(YEAR>=2033 AND MONTH>2,0,1);  VAR4:=LLV(LOW,5);  VAR5:=HHV(HIGH,4);  散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;  庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;  DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'低吸',COLORRED;  DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.15,'高抛',COLORRED;  DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,4);  DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,5);  VAR9:=CLOSE-REF(CLOSE,5);  VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);  VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);  卖出1:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);  DRAWICON(卖出1=90,H+0.05,11); DRAWTEXT(卖出1=90,H+0.15,'线逃',COLORYELLOW; LC := REF(CLOSE,1); BACKGROUNDSTYLE(1); RSI1:SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100; RSI2:SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;  买线:=EMA(CLOSE,2);  卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);  DRAWICON(CROSS(买线,卖线),L-0.06,10); DRAWICON(CROSS(80,RSI1),H+0.06,11); DRAWTEXT(CROSS(80,RSI1),H+0.06,'SI80',COLORYELLOW;
    VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3; A0:=(L+H+C*2)/4; M:5; A1:EMA(A0,M),COLORBLUE,LINETHICK2; A2:=EMA(A0,25),LINETHICK2; A1X:=(A1-REF(A1,1))/REF(A1,1)*100; A2X:=(A2-REF(A2,1))/REF(A2,1)*100; PARTLINE1(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))),COLORMAGENTA; PARTLINE1(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X)))),COLORCYAN; PARTLINE1(A1X>=0,A1),COLORRED,LINETHICK3; PARTLINE1(A1X<0 AND A2X<0,A1),COLORGREEN,LINETHICK3; STICKLINE1(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF; STICKLINE1(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;  STICKLINE1(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;  STICKLINE1(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33; UPQK:=LOW-REF(HIGH,1); STICKLINE1(CLOSE>REF(CLOSE,1) AND UPQK>0,REF(HIGH,1),LOW,20,1),COLORFF00FF; DRAWTEXT(CLOSE>REF(CLOSE,1) AND UPQK>0,UPQK/2+REF(HIGH,1),'向上跳空',COLORFF00FF; DOWNQK:=REF(LOW,1)-HIGH; STICKLINE1(CLOSE<REF(CLOSE,1) AND DOWNQK>0,REF(LOW,1),HIGH,20,1),COLORFFFF00; DRAWTEXT(CLOSE<REF(CLOSE,1) AND DOWNQK>0,DOWNQK/2+HIGH,'向下跳空',COLORFFFF00; MID :  MA(CLOSE,26); UPPER: MID + 2*STD(CLOSE,26),COLORYELLOW; LOWER: MID - 2*STD(CLOSE,26),COLORYELLOW;

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容