短线高手副图指标公式公式、源码-同花顺公式 -程序化交易(CXH99.COM)
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

短线高手副图指标公式公式、源码[同花顺公式]

相关标签:

 

原理解析:


 

 来源:程序化99( WWW.CXH99.COM )

源码:

 

RSVK:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSVK,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
ma3:=MA(C,3);
买入1:=CROSS(C,ma3) AND ma3>=REF(ma3,1)*0.99 ;
买入2:=C>ma3 AND (C-ma3)/ma3<0.035 AND ma3>REF(ma3,1)*0.998 ;
买入3:=C>ma3 AND REF(ma3,1)<REF(ma3,2) AND REF(ma3,2)<REF(ma3,3);
买入4:= C>ma3 AND J<80 AND CROSS(J,D) ;
不买入1:= J>80 OR COUNT( CROSS(D,J),2)>0;
不买入2:=(C-ma3)/ma3>=0.035;
不买入3:=O>C*1.02 ;
不买入4:="CCI">100;
不买入5:=REF(C,1)>REF(ma3,1) AND REF(C,2)>REF(ma3,2);
不买入6:=COUNT(ma3>REF(ma3,1)*1.0015,4)>=3;
判断买入:= NOT(不买入1 OR 不买入2 OR 不买入3 OR 不买入4 OR 不买入5 OR 不买入6) AND (买入1 OR 买入2 OR 买入3 OR 买入4);
买入条件:=FILTER(判断买入,1);
买入: 0.5*((COUNT( REF(买入条件,1),3)=0 OR CROSS(J,D)) AND COUNT( REF(买入条件,1),1)=0 AND 买入条件),colorred;
买入天数:=BARSLAST(买入);
买入价:REF(C,买入天数),linethick0;
手续费:=0.003;
盈亏:100*((C-买入价)/买入价-手续费),linethick0,colore66878;
百分之5止赢:买入价*(1+0.05+手续费),linethick0,color000999;
百分之2止损:买入价*(1-0.025+手续费),colorgreen,linethick0;
止赢条件:=H>=百分之5止赢 AND REF(买入,1)=0 AND REF(L,买入天数-1)<=买入价;
止赢天数:=BARSLAST(止赢条件);
止损条件:=C<百分之2止损 AND REF(买入,1)=0 AND REF(L,买入天数-1)<=买入价;
止损天数:=BARSLAST(止损条件);
止赢:=买入天数> 止赢天数 AND 止赢天数<止损天数 ;
止赢天数2:=BARSLAST(止赢条件 AND 止赢 AND COUNT(REF(止赢,1),1)=0);
止损:=买入天数>止损天数 AND 止赢天数>止损天数;
止损天数2:=BARSLAST(止损 AND COUNT(REF(止损,1),1)=0);
DRAWTEXT(止赢 AND COUNT(REF(止赢,1),1)=0 AND 买入天数<止损天数2,0.5,'止赢');
DRAWICON(止赢 AND COUNT(REF(止赢,1),1)=0 AND 买入天数<止损天数2,0.3,1);
DRAWTEXT(止损 AND COUNT(REF(止损,1),1)=0 AND 买入天数<止赢天数2,-0.4,'止损');
DRAWICON(止损 AND COUNT(REF(止损,1),1)=0 AND 买入天数<止赢天数2,-0.5,2);
逃命价:HHV(H,买入天数)*0.905,linethick0;
逃命条件:=C<逃命价;
逃命天数:=BARSLAST(逃命条件);
逃命:=买入天数>逃命天数 ;
逃命天数2:=BARSLAST(逃命 AND COUNT(REF(逃命,1),1)=0);
DRAWTEXT(逃命条件 AND 逃命天数2=0,-0.3,'逃命');
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26),colorblue;
顶背离:=(HHV(C,60)=REF(C,1)) AND NOT(HHV(diff,60)=REF(diff,1)) AND diff<REF(diff,1);
STICKLINE(顶背离 ,0 ,-0.3 ,4 ,0 ),colorgreen;
DRAWTEXT(顶背离,-0.1,'背离'),colorgreen;
-0.6;
TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.CXH99.COM '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容